Compte utilisateurs en QWERTY

Avatar du membre
christophe
MyEleec d'osmium LV4
MyEleec d'osmium LV4
Messages : 10530
Enregistré le : mai 14, '07, 10:29
Discipline : Electrotechnique
Académie : Créteil
Qui êtes vous ? : Enseignant
Localisation : Seine et marne
A remercié : 13 fois
A été remercié : 27 fois
Contact :

Compte utilisateurs en QWERTY

Message non lu par christophe » sept. 3, '10, 23:08

J'ai pas mal d'utilisateurs dans mon domaine win2003 bloqué en clavier QWERTY.
En repassant administrateur sur ce poste, la machine repasse en azerty !

J'ai tenté par GPO d'imposer le clavier francais, mais cela ne change rien. De plus, j'essaye quand je suis en utilisateurs de configurer les options régionales en français, mais cela revient toujours en anglais ...

Si quelqu'un a une solution, je suis prenneur.

Aide mémoire :
Dérouler ce chemin:
HKEY_USERS\.DEFAULT\Keyboard Layout\Preload
panel de droite: tu devrais avoir ( en plus de la valeur '(par défaut)' :
1 REG_SZ 0000040C

la donnée 0000040c veut dire = "French (Standard)"
Si tu as 00000409 , ça signifie : "English (American)"

Pour la modifier: double-clic sur la valeur nommée 1 et entrer cette chaine de caractères: 0000040C
( c'est une donnée de type REG_SZ c-a-d 'caractères alphabétiques' )

*edit*
faire de même pour:
HKEY_CURRENT_USER\Keyboard Layout\Preload
qui est la clé utilisée pour l'utilisateur 'courant'
À vaincre sans péril, on triomphe sans gloire.
Image Image
Image Image
Image Image
Image

Avatar du membre
christophe
MyEleec d'osmium LV4
MyEleec d'osmium LV4
Messages : 10530
Enregistré le : mai 14, '07, 10:29
Discipline : Electrotechnique
Académie : Créteil
Qui êtes vous ? : Enseignant
Localisation : Seine et marne
A remercié : 13 fois
A été remercié : 27 fois
Contact :

Re: Compte utilisateurs en QWERTY

Message non lu par christophe » sept. 3, '10, 23:36

J'ai tenté un script de démarrage CMD :

Code : Tout sélectionner

reg import \\srv2010-02\wallpaper$\français1.reg
reg import \\srv2010-02\wallpaper$\français2.reg
Voici le contenu des fichiers reg :

Français1.reg : HKEY_USERS\.DEFAULT\Keyboard Layout\PreLoad

Code : Tout sélectionner

Windows Registry Editor Version 5.00
[HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]
"1"="0000040c"


Français2.reg : HKEY_CURRENT_USER\Keyboard Layout\PreLoad

Code : Tout sélectionner

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Keyboard Layout\Preload]
"1"="0000040c"
A voir ce que ca donne ... Sachant que des profs m'ont déjà dit qu'ils libèreraient les élèves si les claviers ne repassent pas en azerty :|
À vaincre sans péril, on triomphe sans gloire.
Image Image
Image Image
Image Image
Image

Avatar du membre
christophe
MyEleec d'osmium LV4
MyEleec d'osmium LV4
Messages : 10530
Enregistré le : mai 14, '07, 10:29
Discipline : Electrotechnique
Académie : Créteil
Qui êtes vous ? : Enseignant
Localisation : Seine et marne
A remercié : 13 fois
A été remercié : 27 fois
Contact :

Re: Compte utilisateurs en QWERTY

Message non lu par christophe » sept. 6, '10, 18:10

AHHHHHHH
ca ne marche pas.
J'ai lu que dans Gunt, chaque utilisateur doit aller chercher un profil "type" à la première utilisation.

J'ai trouvé ce lien :
http://forum.hardware.fr/hfr/WindowsSof ... 0694_1.htm

Je pense que c'est exactement le même problème, mais je ne sais pas ou il faut faire la manipulation...
À vaincre sans péril, on triomphe sans gloire.
Image Image
Image Image
Image Image
Image

Avatar du membre
christophe
MyEleec d'osmium LV4
MyEleec d'osmium LV4
Messages : 10530
Enregistré le : mai 14, '07, 10:29
Discipline : Electrotechnique
Académie : Créteil
Qui êtes vous ? : Enseignant
Localisation : Seine et marne
A remercié : 13 fois
A été remercié : 27 fois
Contact :

Re: Compte utilisateurs en QWERTY

Message non lu par christophe » sept. 7, '10, 08:51

Je vais tester ca :
Bonjour, j'ai eu le même problème sur windows serveur 2003 et client XP SP2
et voila ma solution ^^

1 - Aller sur un poste XP et faire un profil correct en azerty bien sur
2 - se connecter sur le poste XP en admin du domaine
3 - clic droit sur poste de travail - onglet avancé - bouton paramètre profil des utilisateurs
4 - sélectionne ton profil puis bonton copier dans
5 - mettre le chemin ou va être le profil obligatoire - ne pas oublier le bouton Modifier de Autorisé à utiliser (obligatoire), les utilisateurs du domaine par exemple puis bouton OK
6 - Dans le dossier ou se trouve le profil obligatoire renommer ntuser.dat en ntuser.man

Et plus de problème
En passant par se module il n'y a pas qu'une seul copie de fichier il modifie les variable système

bon courage
Source :
Télécharger
Je rajoute à ca un script pour copier les fichiers :

Code : Tout sélectionner

@echo off
rd /s /q "c:\Documents and Settings\Default User"
echo R | xcopy "K:\Deploiement\Default User" "c:\Documents and Settings\Default User" /s /e
Il faut bien sûr changer : K:\Deploiement\Default User par un chemin réseau où se trouve le profil sur le serveur.
J'ai testé tout ca sur des serveurs virtuel, les profils reviennent en français au bout d'une dizaine de secondes.
Je vais tester ca cette après midi au lycée !
À vaincre sans péril, on triomphe sans gloire.
Image Image
Image Image
Image Image
Image

Avatar du membre
forp007
MyEleec de laiton LV3
MyEleec de laiton LV3
Messages : 60
Enregistré le : déc. 21, '09, 15:52
Discipline : STI2D SIN (électronique avant la réforme)
Localisation : bussy saint georges
Contact :

Re: Compte utilisateurs en QWERTY

Message non lu par forp007 » sept. 8, '10, 14:05

Image
Image
Gloire à notre Seigneur Noir et à notre fondateur Xendor.

Avatar du membre
christophe
MyEleec d'osmium LV4
MyEleec d'osmium LV4
Messages : 10530
Enregistré le : mai 14, '07, 10:29
Discipline : Electrotechnique
Académie : Créteil
Qui êtes vous ? : Enseignant
Localisation : Seine et marne
A remercié : 13 fois
A été remercié : 27 fois
Contact :

Re: Compte utilisateurs en QWERTY

Message non lu par christophe » sept. 8, '10, 15:10

Marche pas :D
À vaincre sans péril, on triomphe sans gloire.
Image Image
Image Image
Image Image
Image

Avatar du membre
christophe
MyEleec d'osmium LV4
MyEleec d'osmium LV4
Messages : 10530
Enregistré le : mai 14, '07, 10:29
Discipline : Electrotechnique
Académie : Créteil
Qui êtes vous ? : Enseignant
Localisation : Seine et marne
A remercié : 13 fois
A été remercié : 27 fois
Contact :

Re: Compte utilisateurs en QWERTY

Message non lu par christophe » sept. 10, '10, 08:05

En fait mon message plus haut, ca marchera pour tous les nouveaux comptes.
Pour les anciens, il faudra écraser manuellement les profils par le profil partagé.
À vaincre sans péril, on triomphe sans gloire.
Image Image
Image Image
Image Image
Image

Avatar du membre
christophe
MyEleec d'osmium LV4
MyEleec d'osmium LV4
Messages : 10530
Enregistré le : mai 14, '07, 10:29
Discipline : Electrotechnique
Académie : Créteil
Qui êtes vous ? : Enseignant
Localisation : Seine et marne
A remercié : 13 fois
A été remercié : 27 fois
Contact :

Re: Compte utilisateurs en QWERTY

Message non lu par christophe » sept. 17, '10, 15:31

C'est résolu (pour le moment)

Donc j'ai bien fais comme indiqué dans le message précédent.
Et je dois supprimer les profils de tous les élèves (1500) pour que leur profil vienne chercher le nouveau.

Ca a résolut les bugs suivants :
  • Claviers en anglais,
  • Fermeture de Word et Excel au démarrage
  • Erreur explorer lors d'un clic droit.
À vaincre sans péril, on triomphe sans gloire.
Image Image
Image Image
Image Image
Image

Répondre

Retourner vers « Windows 2003 »